Author Topic: Sanctuary Update - 5/10/18  (Read 339 times)

0 Members and 1 Guest are viewing this topic.

Online Arnox

Sanctuary Update - 5/10/18
« on: May 10, 2018, 11:35:07 PM »
Additions:
- Added BBCode options to the Quick Reply bar at the bottom. Unclick the Toggle View button on the far right to switch back to normal view mode. You can also change which kind of view it will give you in your profile options.

Removals:
- Many sub-forums have been removed and consolidated into one to streamline the forum more.

Changes:
- The default theme has been changed to Neutrality. You can change it back though in your profile options if you like.
« Last Edit: May 11, 2018, 01:16:24 AM by Arnox »

Online Arnox

Re: Sanctuary Update - 5/10/18
« Reply #1 on: May 11, 2018, 01:14:47 AM »
Added a newish Quick Rely box. You guys should be able to use it now. Unclick the Toggle View button on the far right to switch back to normal view mode. You can also change which kind of view it will give you in your profile options.

Offline bluegate

  • Devotee
  • **
  • Posts: 131
    • View Profile
    • luckymouse.nl
Re: Sanctuary Update - 5/10/18
« Reply #2 on: May 11, 2018, 06:00:35 PM »
Wait a second, am I going crazy or has the Post Assistant in the Quick Reply box vanished again? :S

Online Arnox

Re: Sanctuary Update - 5/10/18
« Reply #3 on: May 11, 2018, 06:26:28 PM »
Wait a second, am I going crazy or has the Post Assistant in the Quick Reply box vanished again? :S

Yeah it has. It's been temporarily removed until I find out why it's not working sometimes.

Offline bluegate

  • Devotee
  • **
  • Posts: 131
    • View Profile
    • luckymouse.nl
Re: Sanctuary Update - 5/10/18
« Reply #4 on: May 11, 2018, 06:38:13 PM »
Yeah it has. It's been temporarily removed until I find out why it's not working sometimes.
One thing that I ran into on Chrome was that Quotes, BB Codes and Smilies wouldn't work sometimes.

After some snooping and searching I noticed that they didn't work if I hadn't clicked inside the editor box yet. After clicking inside the editor box, the buttons would work as one would expect.

Here's a thread on it from SMF:
https://www.simplemachines.org/community/index.php?topic=507416.0

I tried applying the fix mentioned in the opening post through Chrome's Developer Tools and it seemed to work, can't speak for any long time effects, of course.

Not sure if the above is what you were experiencing, though.  :-X :)

Online Arnox

Re: Sanctuary Update - 5/10/18
« Reply #5 on: May 11, 2018, 06:49:54 PM »
One thing that I ran into on Chrome was that Quotes, BB Codes and Smilies wouldn't work sometimes.

After some snooping and searching I noticed that they didn't work if I hadn't clicked inside the editor box yet. After clicking inside the editor box, the buttons would work as one would expect.

Here's a thread on it from SMF:
https://www.simplemachines.org/community/index.php?topic=507416.0

I tried applying the fix mentioned in the opening post through Chrome's Developer Tools and it seemed to work, can't speak for any long time effects, of course.

Not sure if the above is what you were experiencing, though.  :-X :)

When the WYSIWYG view was turned off with the BBCode buttons/smilies left on, it would simply not display any of it for me, no matter where the focus was.

Online Arnox

Re: Sanctuary Update - 5/10/18
« Reply #6 on: May 11, 2018, 10:30:58 PM »
Fixed now and readded. Let me know if there's any issues.

Offline bluegate

  • Devotee
  • **
  • Posts: 131
    • View Profile
    • luckymouse.nl
Re: Sanctuary Update - 5/10/18
« Reply #7 on: May 12, 2018, 08:20:35 PM »
Awesome to hear that you got the error fixed that you were running into!


Sad to say, though, that the error as described in my previous post is still present  :P


Not that big of a deal if you know about it, but unknowing users might be confused by it.

Online Arnox

Re: Sanctuary Update - 5/10/18
« Reply #8 on: May 12, 2018, 09:42:36 PM »
Awesome to hear that you got the error fixed that you were running into!


Sad to say, though, that the error as described in my previous post is still present  :P


Not that big of a deal if you know about it, but unknowing users might be confused by it.

That's actually an old error. Are you using an old version of any web browser perchance? Is your PM browser forked from an old version of Chrome?

Offline bluegate

  • Devotee
  • **
  • Posts: 131
    • View Profile
    • luckymouse.nl
Re: Sanctuary Update - 5/10/18
« Reply #9 on: May 13, 2018, 07:59:23 AM »
That's actually an old error. Are you using an old version of any web browser perchance? Is your PM browser forked from an old version of Chrome?
Sad to say that I'm just using 'normal' Chrome, updated to version 66.someNumbers.

Mind if I ask what mod you're using for the Quick Reply post assistant?
Tried on a private copy of SMF 2.0.15 and I'm not running into the same problems there, compared editor.js and they are both identical, so maybe it's something to do with the mod?

Not so much asking to push updates on you, more so out of curiosity as I want to know what is causing this.
« Last Edit: May 13, 2018, 08:09:21 AM by bluegate »

Online Arnox

Re: Sanctuary Update - 5/10/18
« Reply #10 on: May 13, 2018, 08:24:28 AM »
Sad to say that I'm just using 'normal' Chrome, updated to version 66.someNumbers.

Mind if I ask what mod you're using for the Quick Reply post assistant?
Tried on a private copy of SMF 2.0.15 and I'm not running into the same problems there, compared editor.js and they are both identical, so maybe it's something to do with the mod?

Not so much asking to push updates on you, more so out of curiosity as I want to know what is causing this.

WYSIWYG Quick Reply v2.3

Offline bluegate

  • Devotee
  • **
  • Posts: 131
    • View Profile
    • luckymouse.nl
Re: Sanctuary Update - 5/10/18
« Reply #11 on: May 13, 2018, 04:18:46 PM »
Sad to say that I'm just using 'normal' Chrome, updated to version 66.someNumbers.

Mind if I ask what mod you're using for the Quick Reply post assistant?
Tried on a private copy of SMF 2.0.15 and I'm not running into the same problems there, compared editor.js and they are both identical, so maybe it's something to do with the mod?

Not so much asking to push updates on you, more so out of curiosity as I want to know what is causing this.

WYSIWYG Quick Reply v2.3
Thanks!

After some testing, it does seem that the culprit for Chrome is the setFocus function when Rich Text Formatting is turned on.

Ah well.