• Welcome to Sanctuary! Registration has been disabled for now. If you wish to make an account, contact Arnox at [email protected] We have a chatbox but it's disabled until you sign in. All our official content can be found here. If you have any questions, try our FAQ here or make a thread if you have an account!

Search Error

andersonnnunes

⚝Future Author of Things✩are✩Looking✩Up v2.0z⚝
Messages
328
Trying to search for "chrome" right now, but all I get is "A server error occurred. Please try again later."

What gives?
 

Arnox

Veteran
Staff member
Administrator
Global moderator
Clan member
Messages
3,672
I didn't properly update the Enhanced Search addon that I purchased with XF. Sorry. I'll fix it. Will update once it's done.
 

Arnox

Veteran
Staff member
Administrator
Global moderator
Clan member
Messages
3,672
Fixed! Let me know if there's any more issues.
 

Arnox

Veteran
Staff member
Administrator
Global moderator
Clan member
Messages
3,672
Great... I'll update the thread once it's fixed.
 

Arnox

Veteran
Staff member
Administrator
Global moderator
Clan member
Messages
3,672
Search has been fixed.
 

Vendor-Lazarus

Disciple
Clan member
Messages
451
Just a question, but how did this fix relocate the chat to home again (from the forum page, where it was after the last change).
Not complaining..as long as it's there..Just..curious.^^
 

Arnox

Veteran
Staff member
Administrator
Global moderator
Clan member
Messages
3,672
Just a question, but how did this fix relocate the chat to home again (from the forum page, where it was after the last change).
Not complaining..as long as it's there..Just..curious.^^
Actually what happened was the chat add-on update reset the chat position to be on every page, annoyingly enough, and I had to force disable it at many different points to make sure it stayed only on the Home page.

EDIT: Reenabled the pop-up.
 

Vendor-Lazarus

Disciple
Clan member
Messages
451
Actually what happened was the chat add-on update reset the chat position to be on every page, annoyingly enough, and I had to force disable it at many different points to make sure it stayed only on the Home page.

EDIT: Reenabled the pop-up.
Ah, ok. I saw the update thread later and wondered if that could have had anything to do with it, but it didn't say.
 

Arnox

Veteran
Staff member
Administrator
Global moderator
Clan member
Messages
3,672
Oh FFS. I didn't even touch it this time. Fixed now.

I think it's time to start complaining to XenForo. It looks like it's periodically crashing or shutting down or whatever and I have to restart the server to get it back up.
 

Arnox

Veteran
Staff member
Administrator
Global moderator
Clan member
Messages
3,672
EDIT: Looks like it's on our end I guess? Let me know when it happens again so I can dig more thoroughly into what's going on, server side.
 

andersonnnunes

⚝Future Author of Things✩are✩Looking✩Up v2.0z⚝
Messages
328
Broken again.
Nah, just kidding this time.
Don't think I have seen this with any other XF install out there, but asking them about it isn't a bad idea.
The forums is small now so the search isn't super important, just makes it easier to recall a thread, but if/when it grows, reliable search would be very helpful.
 

Arnox

Veteran
Staff member
Administrator
Global moderator
Clan member
Messages
3,672
OK, I think I finally fixed the internal issue. Pretty sure the search service was getting killed because it was running out of memory. I upped the max memory, but we'll see.
 

Arnox

Veteran
Staff member
Administrator
Global moderator
Clan member
Messages
3,672
OK THEN. Since that didn't work, I just configured the damn thing to auto-restart every time it crashes. It fixes all the issues but the actual problem itself is not resolved... I'm tired of messing around with this though.
 
Top